Skip to Content

We received a query over the weekend that’s worth sharing because its the sort of question that I’ll bet many of you have had if you are dealing with an on-board DC to AC inverter.

 

wellcraft
Shannon writes in:

Ed- “I’m having a problem with installing an Inverter in a 86 32′ Wellcraft. it is a 6K run/12K surge inverter. It is connected to two banks of two D8 batteries.
The problem is that the polarity light comes on and the 30A breaker pops when power is applied. So I tried switching the wires on the plug and that did not work. Then I put the shore power connector on side of boat plugged into my shop, everything worked so I unplugged from shop and plugged into inverter same problem. Is the power coming out of the inverter the wrong frequency or what any ideas?”   Shannon

Well Shannon, you haven’t given me quite enough information to be sure I’m giving you the correct answer. But I’ll share some of the common problems we run into with DIY inverter installs.

The first thing that comes to mind is the importance of making sure that the inverter is set up with a break before make switching set up with your shore power system and/or onboard generator. Also, it is important for the neutral and ground inside your inverter get connected only when the inverter is in invert mode. On many inverters this function is a programmable or switchable function depending upon the application. Check the install instructions to make sure this function is activated in marine applications.

Another common problem that can cause some of the issues Shannon mentions is on board connected neutral (white wire) conductors in systems that have either more than one shore power inlet or multiple AC power sources. These neutrals must be kept seperate on board the boat.

Check out those things first and foremost. Odds are good that one of these seemingly small items is the cause of your problem.

[an error occurred while processing this directive]

Comments are closed.